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CALIBRATING NI 4050/4060 DMMS 
WITH CALIBRATION EXECUTIVE

This document contains step-by-step instructions for loading and running 
the National Instruments Calibration Executive procedure for 
NI 4050/4060 digital multimeters (DMMs). 
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Conventions
The following conventions are used in this document:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.

Equipment and Other Test Requirements
This section describes the equipment, test conditions, documentation, and 
software needed to calibrate NI 4050/4060 DMMs.

Test Equipment
To calibrate a National Instruments DMM, you need a calibrator. The 
calibration procedure runs in automated mode if you use a calibrator that 
is supported by IVI. NI recommends using the Fluke 5700A.

If you do not have an IVI-supported calibrator, use a calibrator that is 
four times as accurate as the analog-to-digital converter (ADC) on the 
device —at least 10 ppm (0.001%) accuracy for DC voltage specifications.
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Connectors
You can perform the calibration procedure without banana connectors, but 
connecting and disconnecting are easier with the correct equipment. The 
automated calibration procedure for NI 4050/4060 DMMs is designed to 
work with banana connectors on the cables supplied with the calibrator. 

For current measurements on the NI 4050, use an NI 4050 cable adapter 
and CSM-200 mA current shunt module, shown in Figure 1. Current 
verification is optional—refer to the Loading and Running the Calibration 
Executive Procedure section for more information.

 

Figure 1.  CSM-200 mA Current Shunt Module and NI 4050 Cable 

Test Conditions
Follow these guidelines to optimize the connections and the environment 
during calibration:

• Keep connections to the NI 4050/4060 short. Long cables and wires act 
as antennae, picking up extra noise that can affect measurements.

• Keep relative humidity between 10% and 90%, noncondensing, 
or consult the DMM documentation for the optimum relative humidity.

• Maintain the temperature between 18 °C and 28 °C.

• Allow a warm-up time of at least 30 minutes to ensure that the 
measurement circuitry of the DMM is at a stable operating 
temperature.

Documentation
In addition to this calibration procedure, you may find the following 
documents helpful:

• Calibration Executive Software User Manual

• Specifications for the NI PCMCIA-4050

• Specifications for the NI PXI/PCI-4060

• NI Digital Multimeters Getting Started Guide

You can download these documents from the NI Web site at 
ni.com/manuals.
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You may also need to refer to the NI Digital Multimeters Help, which you 
can find at Start»Programs»National Instruments»NI-DMM» 
Documentation, and the NI-DAQ Help, which you can find at 
Start»Programs»National Instruments»NI-DAQ»NI-DAQ Help.

Software
For information on installing and uninstalling Calibration Executive 
procedures, refer to the Calibration Executive Software User Manual.

The Calibration Executive setup program installs Calibration Executive 
and the associated files listed in Table 1.

Calibration Temperatures
To account for temperature changes, the tested specifications include the 
effects of temperature drift. For NI 4050/4060 DMMs, the following 
temperature drifts are valid:

• 24-hour range—calibration temperature ±3 °C

• 1-year range—calibration temperature ±10 °C

Table 1.  Calibration Executive Directories and Supporting Files

Directory Name Contents

Program Files\National Instruments\ 
Calibration Executive\Procedures\ 
NI4050 NI4060

Directory structure that contains the 
calibration procedure and this document.

Program Files\National Instruments\ 
Calibration Executive\Procedures\ 
NI4050 NI4060\Limits

Microsoft Access databases that store the 
calibration limits.

Program Files\National Instruments\ 
Calibration Executive\Procedures\ 
NI4050 NI4060\Support Files

Support files such as bitmaps and DLLs.



© National Instruments Corporation 5 Calibrating NI 4050/4060 DMMs with Calibration Executive

Calibration Executive Procedures
This section explains how to set up and run the Calibration Executive 
procedure.

In automated mode, the calibration procedure takes approximately 
one hour. In manual mode, the calibration procedure can take up to 
six hours.

Note For an explanation of automated versus manual calibration, refer to the Calibration 
Executive Software User Manual.

Setting Up the NI 4050/4060 for Calibration
To set up the NI 4050/4060 for calibration, complete the following steps:

1. Install the NI 4050/4060 in the host computer according to the 
instructions in the NI Digital Multimeters Getting Started Guide.

2. Configure the hardware using Measurement & Automation Explorer 
(MAX). 

Loading and Running the Calibration Executive Procedure
To run the Calibration Executive procedure, complete the following steps:

1. Launch Calibration Executive.

2. Follow the Calibration Configuration Wizard to load the correct 
calibration procedure. For more information on loading and running 
the calibration procedure, refer to the Calibration Executive Software 
User Manual.

3. When the procedure is loaded, click Run Procedure.

4. When the calibration procedure asks you whether to calculate 
measurement uncertainty, select Yes or No. If you select Yes, you are 
prompted to select the appropriate uncertainty file based on the 
calibrator you are using and when the calibrator was last calibrated.

5. When the calibration procedure prompts you for information about the 
installed hardware, enter the following information:

• Device Number—The number assigned to the DMM by MAX 
when you configured the hardware.

• Supported Products—The appropriate device from the menu 
that lists all of the National Instruments DMMs supported by the 
calibration procedure.

Note If you are calibrating an NI 4050, Calibration Executive also presents the option to 
verify current measurements. Current verification is optional because the NI 4050 is 
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dependent on the CSM-200 mA external current shunt module for current measurements. 
The NI 4050 measures voltage drop across the precision resistor within the CSM-200 mA, 
then translates that voltage into a current. If the NI 4050 fails current verification after you 
have calibrated for voltage measurements, try using another CSM-200 mA or another 
1 Ω precision resistor.

6. Follow any further instructions you receive from Calibration 
Executive.

Viewing the Calibration Report
When the calibration procedure is finished, complete the following steps to 
view the calibration report:

1. Select View»Reports.

2. Click View. 

Modifying the Font Size in a Calibration Report
If you have selected the HTML format and the text size in the calibration 
report is too large, you can decrease the size as follows:

• In Internet Explorer, modify the text size by selecting View»Text Size 
and selecting the appropriate size from the menu.

• In Netscape, modify the text size by selecting View»Decrease Font.

Note If the NI 4050/4060 fails after calibration, refer to the Troubleshooting Guidelines 
section. If the device still fails after you complete the troubleshooting procedures, return it 
to NI for repair or replacement.

Measurement Uncertainty Considerations and 
Calculations

For information on how Calibration Executive handles measurement 
uncertainty, refer to Chapter 3, Measurement Uncertainty, of the 
Calibration Executive Software User Manual.

The NI 4050/4060 calibration procedure runs five main tests. Each test 
takes the same uncertainty components into account. After Calibration 
Executive calculates all the components of uncertainty, the components are 
converted to a 1-sigma normal distribution, then combined using the 
root-sum-square method. The reported expanded uncertainty of 
measurement corresponds to a coverage probability of approximately 95%.



© National Instruments Corporation 7 Calibrating NI 4050/4060 DMMs with Calibration Executive

Table 2 contains the uncertainty budget for resistance, AC voltage, 
DC voltage, AC current, and DC current uncertainties for the 
NI 4050/4060.

Troubleshooting Guidelines
This section describes common problems you might encounter when 
calibrating an NI 4050/4060 and explains how to correct the problem.

If the NI 4050/4060 is not recognized in MAX, make sure that you followed 
the configuration guidelines. Additional configuration information is 
available at ni.com/support/daq. If MAX fails to recognize the 
NI 4050/4060 after you reconfigure, contact NI technical support.

If the NI 4050/4060 fails after calibration, try the following:

1. Check the connections and run the Calibration Executive procedure 
again.

2. If the calibration still fails after trying step 1, try inputting 
or outputting the failed test points using the test panel in MAX or 
the DMM Soft Front Panel, which is located at Start»Programs» 
National Instruments»NI-DMM»NI-DMM Soft Front Panel. 
For example, if the analog input (AI) failed at 1.99 VDC, input that 
value from the calibrator. 

a. Launch the test panel in MAX.

Table 2.  Uncertainty Components

Uncertainty Component Description

Calibrator uncertainty Retrieved from the calibrator uncertainty text file1.

Resolution uncertainty of the 
NI 4050/4060

Retrieved from the limits files.

 
Type A uncertainty 

 

 
where 10 is the number of measurements taken and 
1.06 accounts for the t-distribution. Including the 
t-distribution is only necessary in cases where the number 
of degrees of freedom is not considered infinite.

Leads and wiring Insignificant compared with other uncertainty 
components.

1 For more information on the text file format, refer to the Calibration Executive Software User Manual.

Standard Deviation of Measurements Taken
10

---------------------------------------------------------------------------------------------------------- 1.06×=
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b. Set the Input Limits to ±2.00 V and set the Data Mode to 
DC voltage. 

c. Check the Average Reading indicator.

If the Average Reading falls outside the range of limits shown in the 
calibration report after you complete steps 1 and 2, contact NI for repair or 
replacement. If the Average Reading falls within the limits, you can change 
the calibration report to indicate the passing value.

Note If you have Microsoft Access 2000 or later installed on the computer, you can also 
modify the database containing the test results. By default, this database is located in 
Program Files\National Instruments\Calibration Executive\Databases\ 
Calibration Reports.mdb.

NI-DAQ Errors and Other Errors
This section describes some of the common errors that can occur when 
calibrating NI 4050/4060 DMMs.

Error Code –10005
Error code -10005 indicates that the device number you selected is not 
configured or recognized in MAX. Configure the device in MAX and 
restart Calibration Executive.

Error Code –15
Error code -15 at the beginning of the calibration procedure indicates 
that the computer may be configured to use commas as decimal places. 
Calibration Executive only supports using periods (.) for decimal places. 
To change this configuration on the computer, complete the following 
steps:

1. Select Start»Settings»Control Panel.

2. If you are using Windows Me/98, click Regional Settings. If you are 
using Windows 2000/NT/XP, click Regional Options.

3. Click the Numbers tab and change the Decimal Symbol from a 
comma (,) to a period (.). Change the Digit Grouping Symbol from (.) 
to (,).

Note If you change the Regional Settings or Regional Options on the computer, you may 
want to change them back to the default settings after running the Calibration Executive 
procedure.
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You can find more information on other error codes in the Status Codes 
section of the NI-DAQ Function Reference Help. To launch this help file, 
select Start»Programs»National Instruments»NI-DAQ»NI-DAQ 
Help.

Specifications
For specification information on the NI 4050/4060 you are calibrating, 
refer to one of the following documents:

• The manual calibration procedure for the device, which is available for 
download at ni.com/calibration.

• The product data sheet, which is available for download at 
ni.com/products.

• The hardware documentation for the device, which is available for 
download at ni.com/manuals.

Technical Support Resources

NI Web Support
NI Web support is your first stop for help in solving installation, 
configuration, and application problems and questions. Online 
problem-solving and diagnostic resources include frequently asked 
questions, knowledge bases, product-specific troubleshooting wizards, 
manuals, drivers, software updates, and more. Web support is available 
through the Technical Support section of ni.com.

Worldwide Support
NI has offices located around the world to help address your support needs. 
You can access our branch office Web sites from the Worldwide Offices 
section of ni.com. Branch office Web sites provide up-to-date contact 
information, support phone numbers, e-mail addresses, and current events. 

If you have searched the technical support resources on our Web site 
and still cannot find the answers you need, contact your local office or 
NI corporate. For telephone support in the United States, dial 
512 795 8248. For telephone support outside the United States, contact 
your local branch office: 

Australia 61 2 9672 8846, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada (Calgary) 403 274 9391, Canada (Montreal) 514 288 5722, 
Canada (Ottawa) 613 233 5949, Canada (Québec) 514 694 8521, 
Canada (Toronto) 905 785 0085, Canada (Vancouver) 514 685 7530, 
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China 86 21 6555 7838, Czech Republic 42 02 2423 5774, 
Denmark 45 45 76 26 00, Finland 385 0 9 725 725 11, 
France 33 0 1 48 14 24 24, Germany 49 0 89 741 31 30, 
Greece 30 2 10 42 96 427, Hong Kong 2645 3186, India 91 80 4190000, 
Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 
Korea 82 02 3451 3400, Malaysia 603 9059 6711, 
Mexico 001 800 010 0793, Netherlands 31 0 348 433 466, 
New Zealand 64 09 914 0488, Norway 47 0 32 27 73 00, 
Poland 48 0 22 3390 150, Portugal 351 210 311 210, 
Russia 7 095 238 7139, Singapore 65 6 226 5886, 
Slovenia 386 3 425 4200, South Africa 27 0 11 805 8197, 
Spain 34 91 640 0085, Sweden 46 0 8 587 895 00, 
Switzerland 41 56 200 51 51, Taiwan 886 2 2528 7227, 
United Kingdom 44 0 1635 52354
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